WordPress中/pluggable.php on line 866错误案例分析解决方案

西安工业大学博客出现/pluggable.php on line 866错误了。今日升级空间由香港空间迁移到北京空间出现了小小的一点悲剧,页面访问正常可是打开“页面”Page出现了小小的问题。原本以为是迁移数据库时候数据库编码出现问题,可是经过排查同一个空间的另外一个WP站点Page页面没有错误。毫无头绪的情况下,采用排除法来进行故障排除。

首先我进行了WP的重新更新,结果还是老样子,这样排除了WP程序本身的问题。

联想到数据库WP-Config是否配置错误,删除wp后重新配置结果故障依旧。

删除原来的数据库,然后恢复还是老样子。

百思不得其解时候,我想进入后台登陆,结果上面提示all-in-seo 某个文件错误。试着将All-in-seo删除,故障排除了。为了验证是否正确,我又将插件安装上去,结果故障重现。

事实证明,这个故障出现在我的空间上面是由于all-in-seo引起的。可是当我将,all-in-seo升级后,故障也自动消失。我想,可能是老版本的all-in-seo不兼容新版本的WP。由于这个all-in-seo自己修改过代码,所以不想升级,错过了两次的升级机会。在此,我强烈建议各位Wordpress站长,插件有更新及时更新吧,不然出现故障会让自己非常着急的!本文来自于西安工业大学博客http://xatu.me转载注明出处!