JDK升级到1.7后竟然出现An error has occurred

前两天用360升级完所有软件,打开Eclipse竟然提示an error has occurred。受伤啊…… 度娘了一下发现是JDK 1.7不能用3.X的Eclipse。一想,自己没有升级过JDK啊,怎么回事?
CMD — > java -version 结果发现,JDK竟然奇葩一样的是1.7。坑爹的360,环境都丫的升级。没办法,只好龟速一样的Checking Updata ,好吧以后不用360了。